[digikam] [Bug 380289] New: Cannot write to Albums residing on NFS

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380289] New: Cannot write to Albums residing on NFS

bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380289

            Bug ID: 380289
           Summary: Cannot write to Albums residing on NFS
           Product: digikam
           Version: 5.4.0
          Platform: Kubuntu Packages
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: AlbumsView
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

I can access the Albums residing on an NFS share, digiKam shows the content of
all those. But when moving an image to such an Album, or creating a new Album
there, I get an error "Das Album XYZ existiert nicht mehr" (msgid "Album %1
does not exist anymore")

.) I can write to the according folder in the shell.
.) digiKam still can write to Albums residing on the local fs.
.) The folder/file names are withour special characters.
.) It worked for the same Albums/Folders about 1 month ago.
.) The messages in the shell look unsuspicious:
--
digikam.general: Using  4  CPU core to run threads
digikam.general: Action Thread run  1  new jobs
digikam.general: Event is dispatched through a passive pop-up
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
digikam.iojob: Thread Finished
digikam.general: One job is done
--

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380289] Cannot write to Albums residing on NFS

bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380289

Klemens Dickbauer <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|normal                      |major

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380289] Cannot write to Albums residing on NFS

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380289

Maik Qualmann <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #1 from Maik Qualmann <[hidden email]> ---
There is no error message in the output. Can you post more of the console
output? I also do not think that we have changed anything in the last time.
Please try the latest beta AppImage for testing from www.digikam.org.

Maik

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380289] Cannot write to Albums residing on NFS

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380289

--- Comment #2 from Klemens Dickbauer <[hidden email]> ---
Created attachment 106003
  --> https://bugs.kde.org/attachment.cgi?id=106003&action=edit
Encoded location path problem

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380289] Cannot write to Albums residing on NFS

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380289

--- Comment #3 from Klemens Dickbauer <[hidden email]> ---
Thanks for the comment. I logged all output from startup and viewing it I found
the problematic symptom early in the startup logs:
--
digikam.database: location for  "%2Fdata%2Fmaccheroni%2Fpic"  is available
false
digikam.database: location for  "/home/kdi/Bilder"  is available  true
digikam.database: location for  "/data/local/Bilder"  is available  true
--
So it seems that for whatever reason by whatever process the path to the
location has been URL encoded or something similar.
When looking into digikam's settings I could confirm it (I seemed to have
overlooked that issue before). So for correction I created the same location
again (see screenshot) and deleted the old one. Now it took about 3hrs to scan
the folder again (I hope the local database has not lost any information), but
it works.

You can close the ticket, but I don't know, maybe it's worth the effort to find
out what caused the path encoding, and maybe there is a more efficient way to
fix it than to re-create the new location.

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380289] Cannot write to Albums residing on NFS

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380289

Klemens Dickbauer <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|major                       |minor

--
You are receiving this mail because:
You are the assignee for the bug.
Loading...