[digikam] [Bug 380256] New: digikam crash when adding new collection

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380256] New: digikam crash when adding new collection

bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380256

            Bug ID: 380256
           Summary: digikam crash when adding new collection
           Product: digikam
           Version: 5.5.0
          Platform: Ubuntu Packages
                OS: Linux
            Status: UNCONFIRMED
          Severity: crash
          Priority: NOR
         Component: general
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

install xubuntu zesty 17.04, adding digikam 5.5 with ppa philip5..
classic configuration
when i clik on the button add a new collection digikam crash

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380256] digikam crash when adding new collection

bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380256

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |BACKTRACE
             Status|UNCONFIRMED                 |RESOLVED
          Component|general                     |setup
                 CC|                            |[hidden email]

--- Comment #1 from [hidden email] ---
We need a GDB backtrace to hack. See here for details :

https://www.digikam.org/contribute/

Gilles Caulier

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380256] digikam crash when adding new collection

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380256

--- Comment #2 from [hidden email] ---
*** Bug 380261 has been marked as a duplicate of this bug. ***

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380256] digikam crash when adding new collection

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380256

--- Comment #3 from michel42 <[hidden email]> ---
Created attachment 105774
  --> https://bugs.kde.org/attachment.cgi?id=105774&action=edit
gdb visu

unable to access the backtrace command in gdb !! sorry.. the digikam process is
running
michel    4212  0.4  4.9 257816 197972 pts/0   S    10:18   0:03 gdb digikam
michel    4218  1.2 10.2 3865584 412220 pts/0  Sl+  10:19   0:08
/usr/bin/digikam

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380256] digikam crash when adding new collection

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380256

--- Comment #4 from michel42 <[hidden email]> ---
when a click on the button  "new local collection" unable to continue to use
digikam

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380256] digikam crash when adding new collection

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380256

--- Comment #5 from michel42 <[hidden email]> ---
Created attachment 105775
  --> https://bugs.kde.org/attachment.cgi?id=105775&action=edit
bt gdb add-on

finally, after Ctrl-C in gdb console, access to BT.. see result file
thanks

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380256] digikam crash when adding new collection

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380256

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|BACKTRACE                   |WAITINGFORINFO

--- Comment #6 from [hidden email] ---
#0  syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007fffe94f103f in g_cond_wait () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fffe94d30e7 in g_once_init_enter () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fffbac849d8 in gdk_window_get_type () from
/usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#4  0x00007fffbac84f39 in gdk_window_get_display () from
/usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#5  0x00007fffbacbb420 in gdk_x11_window_get_xid () from
/usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#6  0x00007fffbb86e779 in ?? () from
/usr/lib/x86_64-linux-gnu/qt5/plugins/platformthemes/libqgtk3.so
#7  0x00007fffbb871291 in ?? () from
/usr/lib/x86_64-linux-gnu/qt5/plugins/platformthemes/libqgtk3.so
#8  0x00007ffff53199c0 in QDialogPrivate::setNativeDialogVisible(bool) () from
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#9  0x00007ffff532c0d2 in QFileDialog::setVisible(bool) () from
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#10 0x00007ffff531a8f1 in QDialog::exec() () from
/usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#11 0x00007ffff532d454 in QFileDialog::getExistingDirectoryUrl(QWidget*,
QString const&, QUrl const&,

This open a file dialog through GTK because you use a GTK based desktop. The
crash is inside GTK code. Nice...

This problem must be fixed in 5.6.0 where we drop desktop based file dialog to
use in this case.

Please test the last pre-release 5.6.0 Linux AppImage bundle which include this
fix.

https://drive.google.com/drive/folders/0BzeiVr-byqt5Y0tIRWVWelRJenM

Gilles Caulier

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380256] digikam crash when adding new collection

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380256

--- Comment #7 from michel42 <[hidden email]> ---
thanks to gilles !! after launch the patch.. you can use digikam 5.5.0 with new
local collections.. or prefer to test the 5.6
very good job

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 380256] digikam crash when adding new collection

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=380256

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|WAITINGFORINFO              |FIXED
   Version Fixed In|                            |5.6.0

--
You are receiving this mail because:
You are the assignee for the bug.
Loading...