[digikam] [Bug 375656] New: Tags view (left side) includes grouped images when it shouldn't

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375656] New: Tags view (left side) includes grouped images when it shouldn't

bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375656

            Bug ID: 375656
           Summary: Tags view (left side) includes grouped images when it
                    shouldn't
           Product: digikam
           Version: 5.5.0
          Platform: Other
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: Tags
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

If I tag an image which has images grouped underneath it (which do not have the
same tag) I would not expect these images to show when filtering by tag using
the left side tags view.

But they do.

I would only expect images to be shown that all have this tag applied.

Example:
- Create album with five images 1..5.
- Tag image#1 with "Foobar" tag and drag images 2..5 on image#1 (to group
them).
- Go to tag "Foobar" in the left sidebar.
- Image#1 is shown with a "grouped images" icon. This icon can be clicked to
reveal images 2..5, which do not have this tag.

I would expect the "grouped images" icon only to be visible if there are images
grouped beneath image#1 that *also* have the same tag.

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375656] Tags view (left side) includes grouped images when it shouldn't

bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375656

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
          Component|Tags                        |AlbumsView-Group
                 CC|                            |[hidden email]

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375656] Tags view (left side) includes grouped images when it shouldn't

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375656

--- Comment #1 from Jens <[hidden email]> ---
This bug is still in the 5.6.0 pre-release but it is stranger.

- Tag some images that are grouped
- Go to the tags view on the left side
- Open the tagged group
- Untag the images *inside* the group
  -> they disappear from the tags view, which is correct
- Close the group
- Open the group again
  -> Images inside the group reappear, even if not tagged - this is incorrect

I would expect only tagged images in the tags view, regardless of grouping
status - see previous comment.

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375656] Tags view (left side) includes grouped images when it shouldn't

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375656

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|5.5.0                       |5.6.0

--
You are receiving this mail because:
You are the assignee for the bug.
Loading...