[digikam] [Bug 375346] New: Many tags disappeared from database

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] New: Many tags disappeared from database

bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

            Bug ID: 375346
           Summary: Many tags disappeared from database
           Product: digikam
           Version: 5.4.0
          Platform: MS Windows
                OS: MS Windows
            Status: UNCONFIRMED
          Severity: critical
          Priority: NOR
         Component: Tags
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

I just noticed that many tags disappeared from the database. They still present
in images metadata but are not shown in tags tree (both left and right panels)
nor under the thumbnail.

I am  syncing from images metadata back to the database right now and I see
they are showing back up but the bug is pretty critical.

Sorry, I cannot tell where and how the tags disappeared because I might did not
notice that.

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] Many tags disappeared from database

bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

--- Comment #1 from wildcowboy <[hidden email]> ---
I am already seeing that some tags coming back properly e.g. /Activities/
snowboarding but some of them showing up in the root not in the group e.g.
/snowboarding instead of /Activities/ snowboarding

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] Many tags disappeared from database

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #2 from [hidden email] ---
I never seen this dysfunction before (can you imagine)...

Which kind of database type do you use ?

Gilles Caulier

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] Many tags disappeared from database

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

--- Comment #3 from wildcowboy <[hidden email]> ---
MySQL MariaDB downloaded using the link digiKam provides

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] Many tags disappeared from database

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
          Component|Tags                        |Database-Mysql

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] Many tags disappeared from database

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

--- Comment #4 from [hidden email] ---
So A mysql server, not Mysql internal. Right ?

Can you try with a fresh database using sqlite instead, to see if problem is
reproducible ?

Gilles Caulier

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] Many tags disappeared from database

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

--- Comment #5 from wildcowboy <[hidden email]> ---
(In reply to caulier.gilles from comment #4)
> So A mysql server, not Mysql internal. Right ?
>
> Can you try with a fresh database using sqlite instead, to see if problem is
> reproducible ?
>
> Gilles Caulier

Everything seems to work fine after switching to sqlite. I will keep you posted
if it pops up again though.

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] Many tags disappeared from database

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

--- Comment #6 from [hidden email] ---
new 5.6.0 pre-release as bundle is available here :

https://drive.google.com/drive/folders/0BzeiVr-byqt5Y0tIRWVWelRJenM

Please check if this problem still reproducible with these versions.

Thanks in advance

Gilles Caulier

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] Many tags disappeared from database

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

--- Comment #7 from wildcowboy <[hidden email]> ---
(In reply to caulier.gilles from comment #6)
> new 5.6.0 pre-release as bundle is available here :
>
> https://drive.google.com/drive/folders/0BzeiVr-byqt5Y0tIRWVWelRJenM
>
> Please check if this problem still reproducible with these versions.
>
> Thanks in advance
>
> Gilles Caulier

It never happened again since I switched back to SQLite. You probably were
correct, it was a mySQL related issue.

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 375346] Many tags disappeared from database

bugzilla_noreply
In reply to this post by bugzilla_noreply
https://bugs.kde.org/show_bug.cgi?id=375346

--- Comment #8 from [hidden email] ---
digiKam 5.6.0 is now released and available as bundle for Linux, MacOS and
Windows.

https://www.digikam.org/news/2017-06-21-5.6.0-release-announcement/

Can you check if problem still exists with this version ?

Thanks in advance

Gilles Caulier

--
You are receiving this mail because:
You are the assignee for the bug.
Loading...