[digikam] [Bug 316791] New: when starting "EXPORT TO VIDEO SLIDE SHOW" twice, the procedure will not finish any more

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 316791] New: when starting "EXPORT TO VIDEO SLIDE SHOW" twice, the procedure will not finish any more

Axel Krebs
https://bugs.kde.org/show_bug.cgi?id=316791

            Bug ID: 316791
           Summary: when starting "EXPORT TO VIDEO SLIDE SHOW" twice, the
                    procedure will not finish any more
    Classification: Unclassified
           Product: digikam
           Version: 3.0.0
          Platform: Ubuntu Packages
                OS: Linux
            Status: UNCONFIRMED
          Severity: major
          Priority: NOR
         Component: general
          Assignee: [hidden email]
          Reporter: [hidden email]

Export to Video slide show is a very excituing new tool. Thank you, I am keen
to check it out.

But:
When I start the toll twice, it strts appearently, without ever ending to run.
the prgress-column will not even start anymore.

Reproducible: Always

Steps to Reproduce:
1. start "EXPORT TO VIDEO SLIDE SHOW"
2. interrupt the progress
3. re start "EXPORT TO VIDEO SLIDE SHOW"

Actual Results:  
the prcedure will never come to an end.

Expected Results:  
each(!!) progress within digiKam should be interruptble without prouces
side-effects as memory leaks, and should run within digiKam as it should run as
a single, independent procvess.

I take this as a "serious failure", as it sems to indicate hidden problems.

That's why I select "Major: A major feature is broken"

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Digikam-devel mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/digikam-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[kipiplugins] [Bug 316791] when starting "EXPORT TO VIDEO SLIDE SHOW" twice, the procedure will not finish any more

Gilles Caulier-4
https://bugs.kde.org/show_bug.cgi?id=316791

Gilles Caulier <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]
          Component|general                     |VideoSlideshow
           Assignee|[hidden email]       |[hidden email]
            Product|digikam                     |kipiplugins

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Digikam-devel mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/digikam-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 316791] Starting video slideshow tool twice, the procedure will not finish any more

bugzilla_noreply
In reply to this post by Axel Krebs
https://bugs.kde.org/show_bug.cgi?id=316791

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Assignee|[hidden email]         |[hidden email]
            Version|3.0.0                       |5.5.0
          Component|VideoSlideshow              |VideoSlideshow
            Product|kipiplugins                 |digikam

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 316791] Starting video slideshow tool twice, the procedure will not finish any more

bugzilla_noreply
In reply to this post by Axel Krebs
https://bugs.kde.org/show_bug.cgi?id=316791

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
     Ever confirmed|0                           |1
             Status|RESOLVED                    |REOPENED
         Resolution|UNMAINTAINED                |---

--
You are receiving this mail because:
You are the assignee for the bug.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[digikam] [Bug 316791] Starting video slideshow tool twice, the procedure will not finish any more

bugzilla_noreply
In reply to this post by Axel Krebs
https://bugs.kde.org/show_bug.cgi?id=316791

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
   Version Fixed In|                            |5.6.0
         Resolution|---                         |FIXED
      Latest Commit|                            |https://commits.kde.org/dig
                   |                            |ikam/8dda686cf8c9409c037860
                   |                            |07e47e1f15e1419097

--- Comment #2 from [hidden email] ---
Git commit 8dda686cf8c9409c03786007e47e1f15e1419097 by Gilles Caulier.
Committed on 02/06/2017 at 12:55.
Pushed by cgilles into branch 'master'.

New digiKam Video SlideShow tool based on QtAV/FFMpeg encoder.

The tool replace the older Qt4 kipi plugin based on ImageMagick and GStreamer
which never
work as expected due to run time dependencies with GStreamer which are a big
puzzle to resolve
and don't work under MacOS and Windows.
The tool permit to encode images as a video diaporama.
The tool support many video codecs as X264 or MPEG4 provided by FFMpeg and
is able to store stream as AVI, MKV, or MP4 media.
The tool permit to apply a transition effect between images (same effects than
presentation tool non-OpenGL).
The tool permit to export image from current select or a set of albums
selection (as HTMLGallery tool).
The tool do not permit to encode an audio soundtrack with the video stream due
a bug in QtAV which
have been reported and must be fixed in next QtAV release 1.12.0.
The tool is available currently under digiKam album GUI, but it will be also
available into
ImageEditor, LightTable, and Showfoto (as HTMLGallery, Panorama, Calendar,
etc... tools.)

Screeshots of tool in action :
https://www.flickr.com/photos/digikam/albums/72157684569983835
Related: bug 320725, bug 337605, bug 331625, bug 324646, bug 176727, bug
318297, bug 153061, bug 334089, bug 271751
FIXED-IN: 5.6.0

M  +17   -0    app/main/digikamapp.cpp
M  +1    -0    app/main/digikamapp.h
M  +2    -1    app/main/digikamui5.rc
M  +14   -0    libs/widgets/mainview/dxmlguiwindow.cpp
M  +9    -1    libs/widgets/mainview/dxmlguiwindow.h

https://commits.kde.org/digikam/8dda686cf8c9409c03786007e47e1f15e1419097

--
You are receiving this mail because:
You are the assignee for the bug.
Loading...