Reset "last view" (not starting because of faulty search)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Reset "last view" (not starting because of faulty search)

Daniel-3
Hi there once again,


first, thank you all for this great piece of software and the support I get here on the list.


I ran a extended search for videos with a minimal length of 10 seconds, with no maximum defined. Digikam crashed and wants to execute the database query always when restarting.

So how can I reset this startup-database query? It think it must be in the .config/digikamrc file...


digikam.dbengine: Failure executing query:
 "SELECT DISTINCT Images.id, Images.name, Images.album,\n Albums.albumRoot,\n ImageInformation.rating, Images.category,\n ImageInformation.format, ImageInformation.creationDate,\n Images.modificationDate, Images.fileSize,\n ImageInformation.width, ImageInformation.height\n FROM Images\n INNER JOIN ImageInformation ON Images.id=ImageInformation.imageid\n INNER JOIN Albums ON Albums.id=Images.album\n WHERE Images.status=1 AND Images.id IN\n (SELECT imageid FROM ImageTags\n WHERE tagid=? OR tagid IN (SELECT id FROM TagsTree WHERE pid=?));\n " 
Error messages: "Der Datensatz konnte nicht abgeholt werden" (The entry coulnd't be fetched) "disk I/O error" 10 1 
Bound values:  (QVariant(int, 41), QVariant(int, 41))
digikam.dbengine: Error while executing DBAction [ "listTagRecursive" ] Statement [ "SELECT DISTINCT Images.id, Images.name, Images.album,\n Albums.albumRoot,\n ImageInformation.rating, Images.category,\n ImageInformation.format, ImageInformation.creationDate,\n Images.modificationDate, Images.fileSize,\n ImageInformation.width, ImageInformation.height\n FROM Images\n INNER JOIN ImageInformation ON Images.id=ImageInformation.imageid\n INNER JOIN Albums ON Albums.id=Images.album\n WHERE Images.status=1 AND Images.id IN\n  (SELECT imageid FROM ImageTags\n WHERE tagid=:tagID OR tagid IN (SELECT id FROM TagsTree WHERE pid=:tagPID));\n " ]
digikam.geoiface: "ROADMAP"
digikam.geoiface: "setting backend marble"
digikam.geoiface: "ROADMAP"
digikam.geoiface: ----
digikam.general: Cancel Main Thread
digikam.geoiface: ----
digikam.general: Using  4  CPU core to run threads
digikam.general: Action Thread run  1  new jobs
digikam.dbengine: Failure executing query:
 "SELECT id FROM Albums WHERE albumRoot=? AND relativePath=?;" 
Error messages: "Der Datensatz konnte nicht abgeholt werden" (The entry coulnd't be fetched) "disk I/O error" 10 1 

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Reset "last view" (not starting because of faulty search)

Daniel-3

Ahh, there was this bug: https://bugs.kde.org/show_bug.cgi?id=378855

I try to start with version AppImage 5.6 now.


And it seems to start with that, but not with 5.5


Am 10.08.2017 um 23:55 schrieb Daniel Schweikert:
Hi there once again,


first, thank you all for this great piece of software and the support I get here on the list.


I ran a extended search for videos with a minimal length of 10 seconds, with no maximum defined. Digikam crashed and wants to execute the database query always when restarting.

So how can I reset this startup-database query? It think it must be in the .config/digikamrc file...


digikam.dbengine: Failure executing query:
 "SELECT DISTINCT Images.id, Images.name, Images.album,\n Albums.albumRoot,\n ImageInformation.rating, Images.category,\n ImageInformation.format, ImageInformation.creationDate,\n Images.modificationDate, Images.fileSize,\n ImageInformation.width, ImageInformation.height\n FROM Images\n INNER JOIN ImageInformation ON Images.id=ImageInformation.imageid\n INNER JOIN Albums ON Albums.id=Images.album\n WHERE Images.status=1 AND Images.id IN\n (SELECT imageid FROM ImageTags\n WHERE tagid=? OR tagid IN (SELECT id FROM TagsTree WHERE pid=?));\n " 
Error messages: "Der Datensatz konnte nicht abgeholt werden" (The entry coulnd't be fetched) "disk I/O error" 10 1 
Bound values:  (QVariant(int, 41), QVariant(int, 41))
digikam.dbengine: Error while executing DBAction [ "listTagRecursive" ] Statement [ "SELECT DISTINCT Images.id, Images.name, Images.album,\n Albums.albumRoot,\n ImageInformation.rating, Images.category,\n ImageInformation.format, ImageInformation.creationDate,\n Images.modificationDate, Images.fileSize,\n ImageInformation.width, ImageInformation.height\n FROM Images\n INNER JOIN ImageInformation ON Images.id=ImageInformation.imageid\n INNER JOIN Albums ON Albums.id=Images.album\n WHERE Images.status=1 AND Images.id IN\n  (SELECT imageid FROM ImageTags\n WHERE tagid=:tagID OR tagid IN (SELECT id FROM TagsTree WHERE pid=:tagPID));\n " ]
digikam.geoiface: "ROADMAP"
digikam.geoiface: "setting backend marble"
digikam.geoiface: "ROADMAP"
digikam.geoiface: ----
digikam.general: Cancel Main Thread
digikam.geoiface: ----
digikam.general: Using  4  CPU core to run threads
digikam.general: Action Thread run  1  new jobs
digikam.dbengine: Failure executing query:
 "SELECT id FROM Albums WHERE albumRoot=? AND relativePath=?;" 
Error messages: "Der Datensatz konnte nicht abgeholt werden" (The entry coulnd't be fetched) "disk I/O error" 10 1 


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Reset "last view" (not starting because of faulty search)

Maik Qualmann
The search is stored in the DB. Use the AppImage to delete the search. Now you
can use digiKam-5.5.0 again.

Maik

Am Freitag, 11. August 2017, 00:25:31 CEST schrieb Daniel Schweikert:

> Ahh, there was this bug: https://bugs.kde.org/show_bug.cgi?id=378855
>
> I try to start with version AppImage 5.6 now.
>
>
> And it seems to start with that, but not with 5.5
>
> Am 10.08.2017 um 23:55 schrieb Daniel Schweikert:
> > Hi there once again,
> >
> >
> > first, thank you all for this great piece of software and the support
> > I get here on the list.
> >
> >
> > I ran a extended search for videos with a minimal length of 10
> > seconds, with no maximum defined. Digikam crashed and wants to execute
> > the database query always when restarting.
> >
> > So how can I reset this startup-database query? It think it must be in
> > the .config/digikamrc file...
> >
> > digikam.dbengine: Failure executing query:
> >  "SELECT DISTINCT Images.id, Images.name, Images.album,\n
> >  Albums.albumRoot,\n ImageInformation.rating, Images.category,\n
> >  ImageInformation.format, ImageInformation.creationDate,\n
> >  Images.modificationDate, Images.fileSize,\n ImageInformation.width,
> >  ImageInformation.height\n FROM Images\n INNER JOIN ImageInformation ON
> >  Images.id=ImageInformation.imageid\n INNER JOIN Albums ON
> >  Albums.id=Images.album\n WHERE Images.status=1 AND Images.id IN\n
> >  (SELECT imageid FROM ImageTags\n WHERE tagid=? OR tagid IN (SELECT id
> >  FROM TagsTree WHERE pid=?));\n ">
> > Error messages: "Der Datensatz konnte nicht abgeholt werden" (*The entry
> > coulnd't be fetched)* "disk I/O error" 10 1 Bound values:  (QVariant(int,
> > 41), QVariant(int, 41))
> > digikam.dbengine: Error while executing DBAction [ "listTagRecursive" ]
> > Statement [ "SELECT DISTINCT Images.id, Images.name, Images.album,\n
> > Albums.albumRoot,\n ImageInformation.rating, Images.category,\n
> > ImageInformation.format, ImageInformation.creationDate,\n
> > Images.modificationDate, Images.fileSize,\n ImageInformation.width,
> > ImageInformation.height\n FROM Images\n INNER JOIN ImageInformation ON
> > Images.id=ImageInformation.imageid\n INNER JOIN Albums ON
> > Albums.id=Images.album\n WHERE Images.status=1 AND Images.id IN\n
> > (SELECT imageid FROM ImageTags\n WHERE tagid=:tagID OR tagid IN (SELECT
> > id FROM TagsTree WHERE pid=:tagPID));\n " ] digikam.geoiface: "ROADMAP"
> > digikam.geoiface: "setting backend marble"
> > digikam.geoiface: "ROADMAP"
> > digikam.geoiface: ----
> > digikam.general: Cancel Main Thread
> > digikam.geoiface: ----
> > digikam.general: Using  4  CPU core to run threads
> > digikam.general: Action Thread run  1  new jobs
> >
> > digikam.dbengine: Failure executing query:
> >  "SELECT id FROM Albums WHERE albumRoot=? AND relativePath=?;"
> >
> > Error messages: "Der Datensatz konnte nicht abgeholt werden" (*The entry
> > coulnd't be fetched)* "disk I/O error" 10 1
Loading...