Possible bug: Prevous/Next (Left Key / Right Key) do not respond after applying a flag to an image

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Possible bug: Prevous/Next (Left Key / Right Key) do not respond after applying a flag to an image

AndriusWild
Hello,

I have noticed that if I apply a flag to an image (e.g. press Alt+1) and do not
wait  until the flag symbol in the right panel changed its color, pressing
Left/Right keys does switch pictures Prevous/Next and kind of gets locked. If
I want to use the arrow keys again I need to click on a picture first.

If I do wait for a second or two the keys work properly.

Lazy syncronization is ON.

Is this a bug?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Possible bug: Prevous/Next (Left Key / Right Key) do not respond after applying a flag to an image

Gilles Caulier-4
Hi,

This problem have been already reported in the past in bugzilla. We
need to implement a widget focus proxy to restore the focus after to
run a low level process which interact with the GUI with signals and
slots notifications. If i remember, i see something like this
implemented in Gwenview in the past.

Some files from bugzilla relevant :

https://bugs.kde.org/show_bug.cgi?id=308252
https://bugs.kde.org/show_bug.cgi?id=371635

And certainly more usability issues...

Best

Gilles Caulier


2017-05-31 23:20 GMT+02:00  <[hidden email]>:

> Hello,
>
> I have noticed that if I apply a flag to an image (e.g. press Alt+1) and do not
> wait  until the flag symbol in the right panel changed its color, pressing
> Left/Right keys does switch pictures Prevous/Next and kind of gets locked. If
> I want to use the arrow keys again I need to click on a picture first.
>
> If I do wait for a second or two the keys work properly.
>
> Lazy syncronization is ON.
>
> Is this a bug?
Loading...