[Bug 234425] New: Display only used tags when tag filtering an album

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 234425] New: Display only used tags when tag filtering an album

Bugzilla from olivier.keshavjee@gmail.com
https://bugs.kde.org/show_bug.cgi?id=234425

           Summary: Display only used tags when tag filtering an album
           Product: digikam
           Version: 1.2.0
          Platform: unspecified
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: wishlist
          Priority: NOR
         Component: general
        AssignedTo: [hidden email]
        ReportedBy: [hidden email]


Version:           1.2.0 (using 4.4.2 (KDE 4.4.2) "release 239",
KDE:KDE4:Factory:Desktop / openSUSE_11.2)
Compiler:          gcc
OS:                Linux (i686) release 2.6.31.12-0.2-default

When in an album and browsing pictures through the right pannel "Tag Filters",
it would help if the pannel displays only the tags in the current album, and
the number of picture from the current album only
(or at least that the unused tags would be grayed and smalled).

In the current state, all tags are shown, and the numbers of all pictures
having this tag is shown, even if those pictures are not in the current album.
So when clicking a tag, if there is no pictures tagged in the current album,
nothing is displayed.  

Having only the used tags display would help to chose the one we are
interresting in, knowing that if we want all the pictures with the current tag
we can either use the left pannel "Tags" or browse to a hierarchically prior
album and have all pictures of sub-albums displayed.

It would be nice to have also the number of "Images Without Tags" in bracket as
for the tag.

--
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
_______________________________________________
Digikam-devel mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/digikam-devel
Reply | Threaded
Open this post in threaded view
|

[Bug 234425] Display only used tags when tag filtering an album

Gilles Caulier-4
https://bugs.kde.org/show_bug.cgi?id=234425


Gilles Caulier <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
          Component|general                     |Filter




--
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
_______________________________________________
Digikam-devel mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/digikam-devel
Reply | Threaded
Open this post in threaded view
|

[Bug 234425] Display only used tags when tag filtering an album

Bugzilla from terri.bugs@gmx.com
In reply to this post by Bugzilla from olivier.keshavjee@gmail.com
https://bugs.kde.org/show_bug.cgi?id=234425


[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]




--
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
_______________________________________________
Digikam-devel mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/digikam-devel
Reply | Threaded
Open this post in threaded view
|

[Bug 234425] Display only used tags when tag filtering an album

Bugzilla from olivier.keshavjee@gmail.com
In reply to this post by Bugzilla from olivier.keshavjee@gmail.com
https://bugs.kde.org/show_bug.cgi?id=234425





--- Comment #1 from Olivier Kes <olivier keshavjee gmail com>  2011-08-05 19:36:32 ---
I'm still thinking this would be a convenient feature.

--
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
_______________________________________________
Digikam-devel mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/digikam-devel
Reply | Threaded
Open this post in threaded view
|

[digikam] [Bug 234425] Tags Filter : display only used tags when an album is filtered by tags

Gilles Caulier-4
In reply to this post by Bugzilla from olivier.keshavjee@gmail.com
https://bugs.kde.org/show_bug.cgi?id=234425

Gilles Caulier <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|Display only used tags when |Tags Filter : display only
                   |tag filtering an album      |used tags when an album is
                   |                            |filtered by tags
                 CC|                            |[hidden email]

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Digikam-devel mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/digikam-devel
Reply | Threaded
Open this post in threaded view
|

[digikam] [Bug 234425] Tags Filter : display only used tags when an album is filtered by tags

bugzilla_noreply
In reply to this post by Bugzilla from olivier.keshavjee@gmail.com
https://bugs.kde.org/show_bug.cgi?id=234425

--- Comment #2 from [hidden email] ---
This entry still valid with digiKam 5.0.0 ?

Gilles Caulier

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Digikam-devel mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/digikam-devel
Reply | Threaded
Open this post in threaded view
|

[digikam] [Bug 234425] Tags Filter : display only used tags when an album is filtered by tags

bugzilla_noreply
In reply to this post by Bugzilla from olivier.keshavjee@gmail.com
https://bugs.kde.org/show_bug.cgi?id=234425

MikeF <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #3 from MikeF <[hidden email]> ---
Created attachment 105918
  --> https://bugs.kde.org/attachment.cgi?id=105918&action=edit
Tags Filter

Yes, it is still the same in 5.6

Screenshot is of my tags filter while I am in an Album of untagged images.
Preferably the numbers in brackets should all be (0) since none of the tags
apply to the images in the Album i am currently viewing.

--
You are receiving this mail because:
You are the assignee for the bug.